CVE-2011-1497

A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*

History

22 Oct 2021, 00:01

Type Values Removed Values Added
References (MISC) https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG - (MISC) https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG - Release Notes, Third Party Advisory
References (MISC) https://www.openwall.com/lists/oss-security/2011/04/06/13 - (MISC) https://www.openwall.com/lists/oss-security/2011/04/06/13 - Exploit, Mailing List, Third Party Advisory
CPE cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 4.3
v3 : 6.1

19 Oct 2021, 14:50

Type Values Removed Values Added
New CVE

Information

Published : 2021-10-19 14:15

Updated : 2021-10-22 00:01


NVD link : CVE-2011-1497

Mitre link : CVE-2011-1497


JSON object : View

Products Affected

rubyonrails

  • rails
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')