CVE-2014-3916

The str_buf_cat function in string.c in Ruby 1.9.3, 2.0.0, and 2.1 allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:rubyonrails:rails:1.9.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:*

History

No history.

Information

Published : 2014-11-16 17:59

Updated : 2019-08-08 14:43


NVD link : CVE-2014-3916

Mitre link : CVE-2014-3916


JSON object : View

Products Affected

rubyonrails

  • rails
CWE
CWE-19

Data Processing Errors