CVE-2014-9390

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.
Configurations

Configuration 1 (hide)

AND
OR cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*
OR cpe:2.3:o:apple:mac_os_x:-:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*

Configuration 2 (hide)

AND
cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:*
OR cpe:2.3:o:apple:mac_os_x:-:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:*
cpe:2.3:a:apple:xcode:6.2:-:*:*:*:*:*:*
cpe:2.3:a:apple:xcode:6.2:beta_2:*:*:*:*:*:*

Configuration 4 (hide)

OR cpe:2.3:a:eclipse:egit:*:*:*:*:*:*:*:*
cpe:2.3:a:eclipse:jgit:*:*:*:*:*:*:*:*
cpe:2.3:a:eclipse:jgit:*:*:*:*:*:*:*:*
cpe:2.3:a:libgit2:libgit2:*:*:*:*:*:*:*:*

History

12 May 2021, 20:50

Type Values Removed Values Added
References (MISC) https://libgit2.org/security/ - (MISC) https://libgit2.org/security/ - Product
References (MISC) https://github.com/libgit2/libgit2/commit/928429c5c96a701bcbcafacb2421a82602b36915 - (MISC) https://github.com/libgit2/libgit2/commit/928429c5c96a701bcbcafacb2421a82602b36915 - Third Party Advisory
CPE cpe:2.3:a:eclipse:egit:-:*:*:*:*:*:*:*
cpe:2.3:a:libgit2:libgit2:-:*:*:*:*:*:*:*
cpe:2.3:a:eclipse:jgit:-:*:*:*:*:*:*:*
cpe:2.3:a:eclipse:egit:*:*:*:*:*:*:*:*
cpe:2.3:a:libgit2:libgit2:*:*:*:*:*:*:*:*
cpe:2.3:a:eclipse:jgit:*:*:*:*:*:*:*:*

Information

Published : 2020-02-12 02:15

Updated : 2021-05-17 19:54


NVD link : CVE-2014-9390

Mitre link : CVE-2014-9390


JSON object : View

Products Affected

mercurial

  • mercurial

eclipse

  • egit
  • jgit

apple

  • xcode
  • mac_os_x

microsoft

  • windows

libgit2

  • libgit2

git-scm

  • git
CWE
CWE-20

Improper Input Validation