CVE-2014-9938

contrib/completion/git-prompt.sh in Git before 1.9.3 does not sanitize branch names in the PS1 variable, allowing a malicious repository to cause code execution.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*

History

No history.

Information

Published : 2017-03-20 00:59

Updated : 2020-04-29 20:26


NVD link : CVE-2014-9938

Mitre link : CVE-2014-9938


JSON object : View

Products Affected

git-scm

  • git
CWE
CWE-116

Improper Encoding or Escaping of Output