CVE-2015-8860

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.
References
Link Resource
http://www.openwall.com/lists/oss-security/2016/04/20/11 Mailing List Third Party Advisory
https://nodesecurity.io/advisories/57 Mitigation Vendor Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*

History

No history.

Information

Published : 2017-01-23 21:59

Updated : 2017-01-24 16:13


NVD link : CVE-2015-8860

Mitre link : CVE-2015-8860


JSON object : View

Products Affected

nodejs

  • node.js
CWE
CWE-59

Improper Link Resolution Before File Access ('Link Following')