CVE-2015-8965

Rogue Wave JViews before 8.8 patch 21 and 8.9 before patch 1 allows remote attackers to execute arbitrary Java code that exists in the classpath, such as test code or administration code. The issue exists because the ilog.views.faces.IlvFacesController servlet in jviews-framework-all.jar does not require explicit configuration of servlets that can be called.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:perforce:jviews:*:*:*:*:*:*:*:*
cpe:2.3:a:perforce:jviews:8.9:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:a:oracle:data_integrator:12.2.1.3.0:*:*:*:*:*:*:*
cpe:2.3:a:oracle:data_integrator:12.2.1.4.0:*:*:*:*:*:*:*

History

23 Jul 2022, 10:33

Type Values Removed Values Added
CPE cpe:2.3:a:rogue_wave_software:jviews:8.9:*:*:*:*:*:*:*
cpe:2.3:a:rogue_wave_software:jviews:*:*:*:*:*:*:*:*
cpe:2.3:a:perforce:jviews:8.9:*:*:*:*:*:*:*
cpe:2.3:a:perforce:jviews:*:*:*:*:*:*:*:*
First Time Perforce jviews
Perforce

30 Jan 2021, 02:37

Type Values Removed Values Added
References (MISC) https://www.oracle.com/security-alerts/cpujan2021.html - (MISC) https://www.oracle.com/security-alerts/cpujan2021.html - Third Party Advisory
References (CONFIRM) https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html - (CONFIRM) https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html - Patch
CPE cpe:2.3:a:oracle:data_integrator:12.2.1.4.0:*:*:*:*:*:*:*
cpe:2.3:a:oracle:data_integrator:12.2.1.3.0:*:*:*:*:*:*:*

20 Jan 2021, 15:15

Type Values Removed Values Added
References
  • (MISC) https://www.oracle.com/security-alerts/cpujan2021.html -

Information

Published : 2017-04-06 21:59

Updated : 2023-12-10 12:01


NVD link : CVE-2015-8965

Mitre link : CVE-2015-8965

CVE.ORG link : CVE-2015-8965


JSON object : View

Products Affected

perforce

  • jviews

oracle

  • data_integrator
CWE
CWE-264

Permissions, Privileges, and Access Controls