CVE-2017-1000083

backend/comics/comics-document.c (aka the comic book backend) in GNOME Evince before 3.24.1 allows remote attackers to execute arbitrary commands via a .cbt file that is a TAR archive containing a filename beginning with a "--" command-line option substring, as demonstrated by a --checkpoint-action=exec=bash at the beginning of the filename.
References
Link Resource
http://seclists.org/oss-sec/2017/q3/128 Mailing List Third Party Advisory
http://www.debian.org/security/2017/dsa-3911 Third Party Advisory
http://www.securityfocus.com/bid/99597 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2017:2388 Third Party Advisory
https://bugzilla.gnome.org/show_bug.cgi?id=784630 Issue Tracking Third Party Advisory
https://github.com/GNOME/evince/commit/717df38fd8509bf883b70d680c9b1b3cf36732ee Issue Tracking Patch Third Party Advisory
https://www.exploit-db.com/exploits/45824/ Exploit Third Party Advisory VDB Entry
https://www.exploit-db.com/exploits/46341/ Exploit Third Party Advisory VDB Entry
Configurations

Configuration 1 (hide)

cpe:2.3:a:gnome:evince:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server:7.4:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server:7.5:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server:7.6:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.4:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.6:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*

Information

Published : 2017-09-05 06:29

Updated : 2019-10-03 00:03


NVD link : CVE-2017-1000083

Mitre link : CVE-2017-1000083


JSON object : View

Products Affected

redhat

  • enterprise_linux_server_eus
  • enterprise_linux_server
  • enterprise_linux_workstation
  • enterprise_linux_server_tus
  • enterprise_linux_server_aus
  • enterprise_linux_desktop

debian

  • debian_linux

gnome

  • evince