CVE-2017-2601

Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*

History

23 Jun 2022, 17:15

Type Values Removed Values Added
References
  • (MLIST) http://www.openwall.com/lists/oss-security/2022/06/22/3 -

17 May 2022, 15:15

Type Values Removed Values Added
References
  • (MLIST) http://www.openwall.com/lists/oss-security/2022/05/17/8 -

12 Apr 2022, 15:15

Type Values Removed Values Added
References
  • (MLIST) http://www.openwall.com/lists/oss-security/2022/04/12/5 -
References (BID) http://www.securityfocus.com/bid/95960 - Third Party Advisory, VDB Entry (BID) http://www.securityfocus.com/bid/95960 - VDB Entry, Third Party Advisory

Information

Published : 2018-05-10 13:29

Updated : 2022-06-23 17:15


NVD link : CVE-2017-2601

Mitre link : CVE-2017-2601


JSON object : View

Products Affected

jenkins

  • jenkins
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')