CVE-2017-2897

An exploitable out-of-bounds write vulnerability exists in the read_MSAT function of libxls 1.4. A specially crafted XLS file can cause a memory corruption resulting in remote code execution. An attacker can send malicious XLS file to trigger this vulnerability.
Configurations

Configuration 1 (hide)

cpe:2.3:a:libxls_project:libxls:1.4.0:*:*:*:*:*:*:*

History

No history.

Information

Published : 2017-11-20 22:29

Updated : 2022-04-19 19:15


NVD link : CVE-2017-2897

Mitre link : CVE-2017-2897


JSON object : View

Products Affected

libxls_project

  • libxls
CWE
CWE-787

Out-of-bounds Write