nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
|https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/||Third Party Advisory|
|http://www.securityfocus.com/bid/103952||Third Party Advisory VDB Entry|
|https://access.redhat.com/errata/RHSA-2019:0367||Third Party Advisory|
|https://access.redhat.com/errata/RHSA-2019:0366||Third Party Advisory|
17 Oct 2021, 08:15
|Type||Values Removed||Values Added|