CVE-2018-1000168

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
Configurations

Configuration 1 (hide)

cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*

History

17 Oct 2021, 08:15

Type Values Removed Values Added
References
  • (MLIST) https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html -

Information

Published : 2018-05-08 15:29

Updated : 2021-10-17 08:15


NVD link : CVE-2018-1000168

Mitre link : CVE-2018-1000168


JSON object : View

Products Affected

nodejs

  • node.js

nghttp2

  • nghttp2
CWE
CWE-20

Improper Input Validation

CWE-476

NULL Pointer Dereference