CVE-2018-10733

There is a heap-based buffer over-read in the function ft_font_face_hash of gxps-fonts.c in libgxps through 0.3.0. A crafted input will lead to a remote denial of service attack.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:gnome:libgxps:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:a:redhat:ansible_tower:3.3:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*

Configuration 3 (hide)

cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*

Information

Published : 2018-05-04 17:29

Updated : 2019-10-03 00:03


NVD link : CVE-2018-10733

Mitre link : CVE-2018-10733


JSON object : View

Products Affected

opensuse

  • leap

gnome

  • libgxps

redhat

  • enterprise_linux_server
  • enterprise_linux_workstation
  • ansible_tower
  • enterprise_linux_desktop
CWE
CWE-125

Out-of-bounds Read