CVE-2018-11713

WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp in the libsoup network backend of WebKit, as used in WebKitGTK+ prior to version 2.20.0 or without libsoup 2.62.0, unexpectedly failed to use system proxy settings for WebSocket connections. As a result, users could be deanonymized by crafted web sites via a WebSocket connection.
References
Link Resource
https://bugs.webkit.org/show_bug.cgi?id=126384 Issue Tracking Patch Third Party Advisory
https://security.gentoo.org/glsa/201808-04
https://trac.webkit.org/changeset/228088/webkit Issue Tracking Patch Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:webkitgtk:webkitgtk\+:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:a:gnome:libsoup:*:*:*:*:*:*:*:*

Information

Published : 2018-06-04 14:29

Updated : 2019-10-03 00:03


NVD link : CVE-2018-11713

Mitre link : CVE-2018-11713


JSON object : View

Products Affected

webkitgtk

  • webkitgtk\+

gnome

  • libsoup