CVE-2019-16370

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:gradle:gradle:*:*:*:*:*:*:*:*

History

No history.

Information

Published : 2019-09-16 18:15

Updated : 2021-07-21 11:39


NVD link : CVE-2019-16370

Mitre link : CVE-2019-16370


JSON object : View

Products Affected

gradle

  • gradle
CWE
CWE-20

Improper Input Validation