CVE-2019-1756

A vulnerability in Cisco IOS XE Software could allow an authenticated, remote attacker to execute commands on the underlying Linux shell of an affected device with root privileges. The vulnerability occurs because the affected software improperly sanitizes user-supplied input. An attacker who has valid administrator access to an affected device could exploit this vulnerability by supplying a username with a malicious payload in the web UI and subsequently making a request to a specific endpoint in the web UI. A successful exploit could allow the attacker to run arbitrary commands as the root user, allowing complete compromise of the system.
Configurations

Configuration 1 (hide)

cpe:2.3:o:cisco:ios:11.0\(20.3\):*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:cisco:ios:16.9\(1\):*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:3.2.0ja:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.7.1:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.7.1a:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.7.1b:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.7.2:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.7.3:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1a:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1b:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1c:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1d:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1e:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.1s:*:*:*:*:*:*:*
cpe:2.3:o:cisco:ios_xe:16.8.2:*:*:*:*:*:*:*

Information

Published : 2019-03-28 01:29

Updated : 2019-10-09 23:47


NVD link : CVE-2019-1756

Mitre link : CVE-2019-1756


JSON object : View

Products Affected

cisco

  • ios
  • ios_xe
CWE
CWE-20

Improper Input Validation