CVE-2019-18906

A Improper Authentication vulnerability in cryptctl of SUSE Linux Enterprise Server for SAP 12-SP5, SUSE Manager Server 4.0 allows attackers with access to the hashed password to use it without having to crack it. This issue affects: SUSE Linux Enterprise Server for SAP 12-SP5 cryptctl versions prior to 2.4. SUSE Manager Server 4.0 cryptctl versions prior to 2.4.
References
Link Resource
https://bugzilla.suse.com/show_bug.cgi?id=1186226 Issue Tracking Vendor Advisory
Configurations

Configuration 1 (hide)

AND
cpe:2.3:a:opensuse:cryptctl:*:*:*:*:*:*:*:*
cpe:2.3:o:suse:linux_enterprise_server:12:sp5:*:*:*:sap:*:*

Configuration 2 (hide)

AND
cpe:2.3:a:opensuse:cryptctl:*:*:*:*:*:*:*:*
cpe:2.3:a:suse:manager_server:4.0:*:*:*:*:*:*:*

History

13 Oct 2022, 12:15

Type Values Removed Values Added
Summary A Use of Password Hash Instead of Password for Authentication vulnerability in cryptctl of SUSE Linux Enterprise Server for SAP 12-SP5, SUSE Manager Server 4.0 allows attackers with access to the hashed password to use it without having to crack it. This issue affects: SUSE Linux Enterprise Server for SAP 12-SP5 cryptctl versions prior to 2.4. SUSE Manager Server 4.0 cryptctl versions prior to 2.4. A Improper Authentication vulnerability in cryptctl of SUSE Linux Enterprise Server for SAP 12-SP5, SUSE Manager Server 4.0 allows attackers with access to the hashed password to use it without having to crack it. This issue affects: SUSE Linux Enterprise Server for SAP 12-SP5 cryptctl versions prior to 2.4. SUSE Manager Server 4.0 cryptctl versions prior to 2.4.

08 Jul 2021, 16:31

Type Values Removed Values Added
CPE cpe:2.3:a:opensuse:cryptctl:*:*:*:*:*:*:*:*
cpe:2.3:a:suse:manager_server:4.0:*:*:*:*:*:*:*
cpe:2.3:o:suse:linux_enterprise_server:12:sp5:*:*:*:sap:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 7.5
v3 : 9.8
CWE CWE-287
References (CONFIRM) https://bugzilla.suse.com/show_bug.cgi?id=1186226 - (CONFIRM) https://bugzilla.suse.com/show_bug.cgi?id=1186226 - Issue Tracking, Vendor Advisory

30 Jun 2021, 09:15

Type Values Removed Values Added
New CVE

Information

Published : 2021-06-30 09:15

Updated : 2023-01-19 13:15


NVD link : CVE-2019-18906

Mitre link : CVE-2019-18906


JSON object : View

Products Affected

suse

  • manager_server
  • linux_enterprise_server

opensuse

  • cryptctl
CWE
CWE-287

Improper Authentication