CVE-2019-20053

An invalid memory address dereference was discovered in the canUnpack function in p_mach.cpp in UPX 3.95 via a crafted Mach-O file.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:upx_project:upx:3.95:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:*
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*

History

01 Jan 2022, 20:08

Type Values Removed Values Added
References (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00007.html - (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00007.html - Mailing List, Third Party Advisory
References (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00003.html - (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00003.html - Mailing List, Third Party Advisory
CWE CWE-20 CWE-119
First Time Opensuse
Opensuse backports
Opensuse leap
CPE cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:*
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*

Information

Published : 2019-12-27 22:15

Updated : 2022-01-01 20:08


NVD link : CVE-2019-20053

Mitre link : CVE-2019-20053


JSON object : View

Products Affected

opensuse

  • leap
  • backports

upx_project

  • upx
CWE
CWE-119

Improper Restriction of Operations within the Bounds of a Memory Buffer