CVE-2019-25009

An issue was discovered in the http crate before 0.1.20 for Rust. The HeaderMap::Drain API can use a raw pointer, defeating soundness.
References
Link Resource
https://rustsec.org/advisories/RUSTSEC-2019-0034.html Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:hyper:http:*:*:*:*:*:rust:*:*

Information

Published : 2020-12-31 10:15

Updated : 2021-01-06 20:26


NVD link : CVE-2019-25009

Mitre link : CVE-2019-25009


JSON object : View

Products Affected

hyper

  • http
CWE
CWE-415

Double Free