CVE-2019-25159

A vulnerability was found in mpedraza2020 Intranet del Monterroso up to 4.50.0. It has been classified as critical. This affects an unknown part of the file config/cargos.php. The manipulation of the argument dni_profe leads to sql injection. Upgrading to version 4.51.0 is able to address this issue. The identifier of the patch is 678190bee1dfd64b54a2b0e88abfd009e78adce8. It is recommended to upgrade the affected component. The identifier VDB-252717 was assigned to this vulnerability.
Configurations

Configuration 1 (hide)

cpe:2.3:a:mpedraza2020:intranet_del_monterroso:*:*:*:*:*:*:*:*

History

12 Feb 2024, 19:52

Type Values Removed Values Added
References () https://github.com/mpedraza2020/IESMONTEROSOINTRANET/commit/678190bee1dfd64b54a2b0e88abfd009e78adce8 - () https://github.com/mpedraza2020/IESMONTEROSOINTRANET/commit/678190bee1dfd64b54a2b0e88abfd009e78adce8 - Patch
References () https://github.com/mpedraza2020/IESMONTEROSOINTRANET/releases/tag/v4.51.0 - () https://github.com/mpedraza2020/IESMONTEROSOINTRANET/releases/tag/v4.51.0 - Release Notes
References () https://vuldb.com/?ctiid.252717 - () https://vuldb.com/?ctiid.252717 - Permissions Required
References () https://vuldb.com/?id.252717 - () https://vuldb.com/?id.252717 - Permissions Required
CPE cpe:2.3:a:mpedraza2020:intranet_del_monterroso:*:*:*:*:*:*:*:*
Summary
  • (es) Se encontró una vulnerabilidad en mpedraza2020 Intranet del Monterroso hasta 4.50.0. Ha sido clasificada como crítica. Esto afecta a una parte desconocida del archivo config/cargos.php. La manipulación del argumento dni_profe conduce a la inyección sql. La actualización a la versión 4.51.0 puede solucionar este problema. El identificador del parche es 678190bee1dfd64b54a2b0e88abfd009e78adce8. Se recomienda actualizar el componente afectado. A esta vulnerabilidad se le asignó el identificador VDB-252717.
First Time Mpedraza2020
Mpedraza2020 intranet Del Monterroso
CVSS v2 : 5.2
v3 : 5.5
v2 : 5.2
v3 : 9.8

04 Feb 2024, 06:15

Type Values Removed Values Added
New CVE

Information

Published : 2024-02-04 06:15

Updated : 2024-02-29 01:25


NVD link : CVE-2019-25159

Mitre link : CVE-2019-25159

CVE.ORG link : CVE-2019-25159


JSON object : View

Products Affected

mpedraza2020

  • intranet_del_monterroso
CWE
CWE-89

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')