CVE-2019-7637

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer overflow in SDL_FillRect in video/SDL_surface.c.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:libsdl:simple_directmedia_layer:*:*:*:*:*:*:*:*
cpe:2.3:a:libsdl:simple_directmedia_layer:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*
cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*

Information

Published : 2019-02-08 11:29

Updated : 2020-08-24 17:37


NVD link : CVE-2019-7637

Mitre link : CVE-2019-7637


JSON object : View

Products Affected

opensuse

  • leap

debian

  • debian_linux

libsdl

  • simple_directmedia_layer
CWE
CWE-787

Out-of-bounds Write