CVE-2020-10724

A vulnerability was found in DPDK versions 18.11 and above. The vhost-crypto library code is missing validations for user-supplied values, potentially allowing an information leak through an out-of-bounds memory read.
Configurations

Configuration 1 (hide)

cpe:2.3:a:dpdk:data_plane_development_kit:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*

Information

Published : 2020-05-19 19:15

Updated : 2021-10-19 14:17


NVD link : CVE-2020-10724

Mitre link : CVE-2020-10724


JSON object : View

Products Affected

canonical

  • ubuntu_linux

dpdk

  • data_plane_development_kit

fedoraproject

  • fedora
CWE
CWE-125

Out-of-bounds Read