CVE-2020-14172

This issue exists to document that a security improvement in the way that Jira Server and Data Center use velocity templates has been implemented. The way in which velocity templates were used in Atlassian Jira Server and Data Center in affected versions allowed remote attackers to achieve remote code execution via insecure deserialization, if they were able to exploit a server side template injection vulnerability. The affected versions are before version 7.13.0, from version 8.0.0 before 8.5.0, and from version 8.6.0 before version 8.8.1.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:atlassian:jira:*:*:*:*:*:*:*:*
cpe:2.3:a:atlassian:jira:*:*:*:*:*:*:*:*
cpe:2.3:a:atlassian:jira:*:*:*:*:*:*:*:*
cpe:2.3:a:atlassian:jira_software_data_center:*:*:*:*:*:*:*:*
cpe:2.3:a:atlassian:jira_software_data_center:*:*:*:*:*:*:*:*
cpe:2.3:a:atlassian:jira_software_data_center:*:*:*:*:*:*:*:*

History

03 May 2022, 13:59

Type Values Removed Values Added
CWE CWE-74 CWE-502
References (MISC) https://jira.atlassian.com/browse/JRASERVER-70940 - Permissions Required (MISC) https://jira.atlassian.com/browse/JRASERVER-70940 - Vendor Advisory

Information

Published : 2020-07-03 02:15

Updated : 2022-05-03 13:59


NVD link : CVE-2020-14172

Mitre link : CVE-2020-14172


JSON object : View

Products Affected

atlassian

  • jira
  • jira_software_data_center
CWE
CWE-502

Deserialization of Untrusted Data