CVE-2020-16289

A buffer overflow vulnerability in cif_print_page() in devices/gdevcif.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.
Configurations

Configuration 1 (hide)

cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*

History

24 Aug 2022, 19:24

Type Values Removed Values Added
References (MLIST) https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html - (MLIST) https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html - Mailing List, Third Party Advisory
References (UBUNTU) https://usn.ubuntu.com/4469-1/ - (UBUNTU) https://usn.ubuntu.com/4469-1/ - Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2020/dsa-4748 - (DEBIAN) https://www.debian.org/security/2020/dsa-4748 - Third Party Advisory
References (GENTOO) https://security.gentoo.org/glsa/202008-20 - (GENTOO) https://security.gentoo.org/glsa/202008-20 - Third Party Advisory
First Time Canonical
Debian debian Linux
Debian
Canonical ubuntu Linux
CPE cpe:2.3:a:artifex:ghostscript:9.50:*:*:*:*:*:*:* cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*

Information

Published : 2020-08-13 03:15

Updated : 2022-08-24 19:24


NVD link : CVE-2020-16289

Mitre link : CVE-2020-16289


JSON object : View

Products Affected

debian

  • debian_linux

canonical

  • ubuntu_linux

artifex

  • ghostscript
CWE
CWE-787

Out-of-bounds Write