CVE-2020-16291

A buffer overflow vulnerability in contrib/gdevdj9.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.
Configurations

Configuration 1 (hide)

cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*

History

07 Nov 2023, 03:18

Type Values Removed Values Added
References
  • {'url': 'http://git.ghostscript.com/?p=ghostpdl.git;h=4f73e8b4d578e69a17f452fa60d2130c5faaefd6', 'name': 'http://git.ghostscript.com/?p=ghostpdl.git;h=4f73e8b4d578e69a17f452fa60d2130c5faaefd6', 'tags': ['Patch', 'Vendor Advisory'], 'refsource': 'MISC'}
  • () http://git.ghostscript.com/?p=ghostpdl.git%3Bh=4f73e8b4d578e69a17f452fa60d2130c5faaefd6 -

24 Aug 2022, 19:24

Type Values Removed Values Added
CPE cpe:2.3:a:artifex:ghostscript:9.50:*:*:*:*:*:*:* cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*
First Time Canonical
Debian debian Linux
Debian
Canonical ubuntu Linux
References (MLIST) https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html - (MLIST) https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html - Mailing List, Third Party Advisory
References (UBUNTU) https://usn.ubuntu.com/4469-1/ - (UBUNTU) https://usn.ubuntu.com/4469-1/ - Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2020/dsa-4748 - (DEBIAN) https://www.debian.org/security/2020/dsa-4748 - Third Party Advisory
References (GENTOO) https://security.gentoo.org/glsa/202008-20 - (GENTOO) https://security.gentoo.org/glsa/202008-20 - Third Party Advisory

Information

Published : 2020-08-13 03:15

Updated : 2023-12-10 13:27


NVD link : CVE-2020-16291

Mitre link : CVE-2020-16291

CVE.ORG link : CVE-2020-16291


JSON object : View

Products Affected

canonical

  • ubuntu_linux

debian

  • debian_linux

artifex

  • ghostscript
CWE
CWE-787

Out-of-bounds Write