CVE-2020-23319

There is an Assertion in '(flags >> CBC_STACK_ADJUST_SHIFT) >= CBC_STACK_ADJUST_BASE || (CBC_STACK_ADJUST_BASE - (flags >> CBC_STACK_ADJUST_SHIFT)) <= context_p->stack_depth' in parser_emit_cbc_backward_branch in JerryScript 2.2.0.
References
Link Resource
https://github.com/jerryscript-project/jerryscript/issues/3834 Exploit Issue Tracking Patch Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:jerryscript:jerryscript:2.2.0:*:*:*:*:*:*:*

Information

Published : 2021-06-10 23:15

Updated : 2021-06-16 18:39


NVD link : CVE-2020-23319

Mitre link : CVE-2020-23319


JSON object : View

Products Affected

jerryscript

  • jerryscript
CWE
CWE-617

Reachable Assertion