CVE-2020-5267

In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:rubyonrails:actionview:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:actionview:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*

History

No history.

Information

Published : 2020-03-19 18:15

Updated : 2020-10-05 02:15


NVD link : CVE-2020-5267

Mitre link : CVE-2020-5267


JSON object : View

Products Affected

rubyonrails

  • actionview

debian

  • debian_linux
CWE
CWE-80

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')