CVE-2020-7063

In PHP versions 7.2.x below 7.2.28, 7.3.x below 7.3.15 and 7.4.x below 7.4.3, when creating PHAR archive using PharData::buildFromIterator() function, the files are added with default permissions (0666, or all access) even if the original files on the filesystem were with more restrictive permissions. This may result in files having more lax permissions than intended when such archive is extracted.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:*

Configuration 3 (hide)

OR cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

Configuration 4 (hide)

cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*

History

08 May 2022, 23:50

Type Values Removed Values Added
References
  • (CONFIRM) https://www.tenable.com/security/tns-2021-14 - Patch, Third Party Advisory
References (MLIST) https://lists.debian.org/debian-lts-announce/2020/03/msg00034.html - (MLIST) https://lists.debian.org/debian-lts-announce/2020/03/msg00034.html - Third Party Advisory
References (GENTOO) https://security.gentoo.org/glsa/202003-57 - (GENTOO) https://security.gentoo.org/glsa/202003-57 - Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2020/dsa-4717 - (DEBIAN) https://www.debian.org/security/2020/dsa-4717 - Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2020/dsa-4719 - (DEBIAN) https://www.debian.org/security/2020/dsa-4719 - Third Party Advisory
References (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html - (SUSE) http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html - Third Party Advisory
References (UBUNTU) https://usn.ubuntu.com/4330-1/ - (UBUNTU) https://usn.ubuntu.com/4330-1/ - Third Party Advisory
CPE cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
First Time Debian debian Linux
Tenable tenable.sc
Debian
Opensuse leap
Tenable
Opensuse

Information

Published : 2020-02-27 21:15

Updated : 2022-05-08 23:50


NVD link : CVE-2020-7063

Mitre link : CVE-2020-7063


JSON object : View

Products Affected

opensuse

  • leap

debian

  • debian_linux

tenable

  • tenable.sc

php

  • php
CWE
CWE-281

Improper Preservation of Permissions