CVE-2021-21100

Adobe Digital Editions version 4.5.11.187245 (and earlier) is affected by a Privilege Escalation vulnerability during installation. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary file system write in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Configurations

Configuration 1 (hide)

AND
cpe:2.3:a:adobe:digital_editions:*:*:*:*:*:*:*:*
cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:*

History

08 Sep 2021, 17:23

Type Values Removed Values Added
CPE cpe:2.3:o:apple:mac_os:-:*:*:*:*:*:*:* cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:*

20 Apr 2021, 21:40

Type Values Removed Values Added
CVSS v2 : unknown
v3 : 7.8
v2 : 6.8
v3 : 7.8
References (MISC) https://helpx.adobe.com/security/products/Digital-Editions/apsb21-26.html - (MISC) https://helpx.adobe.com/security/products/Digital-Editions/apsb21-26.html - Vendor Advisory
CPE cpe:2.3:a:adobe:digital_editions:*:*:*:*:*:*:*:*
cpe:2.3:o:apple:mac_os:-:*:*:*:*:*:*:*

15 Apr 2021, 14:37

Type Values Removed Values Added
New CVE

Information

Published : 2021-04-15 14:15

Updated : 2021-09-08 17:23


NVD link : CVE-2021-21100

Mitre link : CVE-2021-21100


JSON object : View

Products Affected

adobe

  • digital_editions

apple

  • macos
CWE
CWE-379

Creation of Temporary File in Directory with Insecure Permissions