CVE-2021-21331

The Java client for the Datadog API before version 1.0.0-beta.9 has a local information disclosure of sensitive information downloaded via the API using the API Client. The Datadog API is executed on a unix-like system with multiple users. The API is used to download a file containing sensitive information. This sensitive information is exposed locally to other users. This vulnerability exists in the API Client for version 1 and 2. The method `prepareDownloadFilecreates` creates a temporary file with the permissions bits of `-rw-r--r--` on unix-like systems. On unix-like systems, the system temporary directory is shared between users. As such, the contents of the file downloaded via the `downloadFileFromResponse` method will be visible to all other users on the local system. Analysis of the finding determined that the affected code was unused, meaning that the exploitation likelihood is low. The unused code has been removed, effectively mitigating this issue. This issue has been patched in version 1.0.0-beta.9. As a workaround one may specify `java.io.tmpdir` when starting the JVM with the flag `-Djava.io.tmpdir`, specifying a path to a directory with `drw-------` permissions owned by `dd-agent`.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta1:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta2:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta3:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta4:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta5:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta6:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta7:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta8:*:*:*:*:*:*

History

10 Mar 2021, 19:40

Type Values Removed Values Added
References (CONFIRM) https://github.com/DataDog/datadog-api-client-java/security/advisories/GHSA-2cxf-6567-7pp6 - (CONFIRM) https://github.com/DataDog/datadog-api-client-java/security/advisories/GHSA-2cxf-6567-7pp6 - Patch, Third Party Advisory
References (CONFIRM) https://github.com/DataDog/datadog-api-client-java/releases/tag/datadog-api-client-1.0.0-beta.9 - (CONFIRM) https://github.com/DataDog/datadog-api-client-java/releases/tag/datadog-api-client-1.0.0-beta.9 - Third Party Advisory
CVSS v2 : unknown
v3 : unknown
v2 : 4.3
v3 : 3.3
CWE NVD-CWE-Other
CPE cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta7:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta1:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta5:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta6:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta2:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta3:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta8:*:*:*:*:*:*
cpe:2.3:a:datadoghq:datadog-api-client-java:1.0.0:beta4:*:*:*:*:*:*

04 Mar 2021, 00:15

Type Values Removed Values Added
New CVE

Information

Published : 2021-03-03 23:15

Updated : 2021-03-10 19:40


NVD link : CVE-2021-21331

Mitre link : CVE-2021-21331


JSON object : View

Products Affected

datadoghq

  • datadog-api-client-java
CWE
NVD-CWE-Other CWE-378

Creation of Temporary File With Insecure Permissions

CWE-379

Creation of Temporary File in Directory with Insecure Permissions