CVE-2021-22885

A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the `redirect_to` or `polymorphic_url`helper with untrusted user input.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:a:rubyonrails:actionpack_page-caching:-:*:*:*:*:*:*:*

Configuration 3 (hide)

cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

History

06 Apr 2022, 16:58

Type Values Removed Values Added
References
  • (CONFIRM) https://security.netapp.com/advisory/ntap-20210805-0009/ - Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2021/dsa-4929 - (DEBIAN) https://www.debian.org/security/2021/dsa-4929 - Third Party Advisory
First Time Debian
Debian debian Linux
CPE cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

10 Jun 2021, 16:15

Type Values Removed Values Added
References
  • (DEBIAN) https://www.debian.org/security/2021/dsa-4929 -

10 Jun 2021, 15:33

Type Values Removed Values Added
CPE cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:actionpack_page-caching:-:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 5.0
v3 : 7.5
CWE CWE-209
References (MISC) https://hackerone.com/reports/1106652 - (MISC) https://hackerone.com/reports/1106652 - Exploit, Third Party Advisory

27 May 2021, 12:15

Type Values Removed Values Added
New CVE

Information

Published : 2021-05-27 12:15

Updated : 2022-04-06 16:58


NVD link : CVE-2021-22885

Mitre link : CVE-2021-22885


JSON object : View

Products Affected

debian

  • debian_linux

rubyonrails

  • actionpack_page-caching
  • rails
CWE
CWE-209

Generation of Error Message Containing Sensitive Information