CVE-2021-22904

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*

History

20 Sep 2021, 13:51

Type Values Removed Values Added
References
  • (CONFIRM) https://security.netapp.com/advisory/ntap-20210805-0009/ - Third Party Advisory

22 Jun 2021, 17:36

Type Values Removed Values Added
References (MISC) https://hackerone.com/reports/1101125 - (MISC) https://hackerone.com/reports/1101125 - Permissions Required, Third Party Advisory
References (MISC) https://discuss.rubyonrails.org/t/cve-2021-22904-possible-dos-vulnerability-in-action-controller-token-authentication/77869 - (MISC) https://discuss.rubyonrails.org/t/cve-2021-22904-possible-dos-vulnerability-in-action-controller-token-authentication/77869 - Exploit, Mitigation, Patch, Vendor Advisory
CPE cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*
CWE NVD-CWE-Other
CVSS v2 : unknown
v3 : unknown
v2 : 5.0
v3 : 7.5

11 Jun 2021, 17:18

Type Values Removed Values Added
New CVE

Information

Published : 2021-06-11 16:15

Updated : 2021-09-20 13:51


NVD link : CVE-2021-22904

Mitre link : CVE-2021-22904


JSON object : View

Products Affected

rubyonrails

  • rails