CVE-2021-25981

In Talkyard, regular versions v0.2021.20 through v0.2021.33 and dev versions v0.2021.20 through v0.2021.34, are vulnerable to Insufficient Session Expiration. This may allow an attacker to reuse the admin’s still-valid session token even when logged-out, to gain admin privileges, given the attacker is able to obtain that token (via other, hypothetical attacks)
Configurations

Configuration 1 (hide)

cpe:2.3:a:talkyard:talkyard:*:*:*:*:*:*:*:*

History

14 Jan 2022, 18:26

Type Values Removed Values Added
First Time Talkyard talkyard
Talkyard
CPE cpe:2.3:a:talkyard:talkyard:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 10.0
v3 : 9.8
CWE CWE-613
References (MISC) https://github.com/debiki/talkyard/commit/b0310df019887f3464895529c773bc7d85ddcf34 - (MISC) https://github.com/debiki/talkyard/commit/b0310df019887f3464895529c773bc7d85ddcf34 - Patch, Third Party Advisory
References (MISC) https://github.com/debiki/talkyard/commit/b0712915d8a22a20b09a129924e8a29c25ae5761 - (MISC) https://github.com/debiki/talkyard/commit/b0712915d8a22a20b09a129924e8a29c25ae5761 - Patch, Third Party Advisory
References (MISC) https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25981 - (MISC) https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25981 - Patch, Third Party Advisory, VDB Entry

03 Jan 2022, 07:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-01-03 07:15

Updated : 2022-01-14 18:26


NVD link : CVE-2021-25981

Mitre link : CVE-2021-25981


JSON object : View

Products Affected

talkyard

  • talkyard
CWE
CWE-613

Insufficient Session Expiration