CVE-2021-27697

RIOT-OS 2021.01 contains a buffer overflow vulnerability in sys/net/gnrc/routing/rpl/gnrc_rpl_validation.c through the gnrc_rpl_validation_options() function.
References
Link Resource
https://github.com/RIOT-OS/RIOT/issues/16062 Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:o:riot-os:riot:2021.01:*:*:*:*:*:*:*

Information

Published : 2021-04-06 13:15

Updated : 2021-04-09 18:06


NVD link : CVE-2021-27697

Mitre link : CVE-2021-27697


JSON object : View

Products Affected

riot-os

  • riot
CWE
CWE-120

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')