CVE-2021-27698

RIOT-OS 2021.01 contains a buffer overflow vulnerability in /sys/net/gnrc/routing/rpl/gnrc_rpl_control_messages.c through the _parse_options() function.
References
Link Resource
https://github.com/RIOT-OS/RIOT/issues/16085 Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:o:riot-os:riot:2021.01:*:*:*:*:*:*:*

Information

Published : 2021-04-06 13:15

Updated : 2021-04-09 17:58


NVD link : CVE-2021-27698

Mitre link : CVE-2021-27698


JSON object : View

Products Affected

riot-os

  • riot
CWE
CWE-120

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')