CVE-2021-3007

Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:getlaminas:laminas-http:*:*:*:*:*:*:*:*
cpe:2.3:a:zend:zend_framework:3.0.0:*:*:*:*:*:*:*

History

07 Nov 2023, 03:37

Type Values Removed Values Added
Summary ** DISPUTED ** Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized. Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized

27 May 2022, 13:28

Type Values Removed Values Added
References (MISC) https://research.checkpoint.com/2021/freakout-leveraging-newest-vulnerabilities-for-creating-a-botnet/ - (MISC) https://research.checkpoint.com/2021/freakout-leveraging-newest-vulnerabilities-for-creating-a-botnet/ - Exploit, Third Party Advisory

19 Jan 2021, 17:15

Type Values Removed Values Added
References
  • (MISC) https://research.checkpoint.com/2021/freakout-leveraging-newest-vulnerabilities-for-creating-a-botnet/ -

13 Jan 2021, 16:04

Type Values Removed Values Added
References (MISC) https://github.com/laminas/laminas-http/pull/48 - (MISC) https://github.com/laminas/laminas-http/pull/48 - Patch, Third Party Advisory
References (MISC) https://github.com/Ling-Yizhou/zendframework3-/blob/main/zend%20framework3%20%E5%8F%8D%E5%BA%8F%E5%88%97%E5%8C%96%20rce.md - (MISC) https://github.com/Ling-Yizhou/zendframework3-/blob/main/zend%20framework3%20%E5%8F%8D%E5%BA%8F%E5%88%97%E5%8C%96%20rce.md - Exploit, Third Party Advisory
References (MISC) https://github.com/laminas/laminas-http/releases/tag/2.14.2 - (MISC) https://github.com/laminas/laminas-http/releases/tag/2.14.2 - Third Party Advisory
References (MISC) https://github.com/laminas/laminas-http/commits/2.15.x/src/Response/Stream.php - (MISC) https://github.com/laminas/laminas-http/commits/2.15.x/src/Response/Stream.php - Patch, Third Party Advisory
CPE cpe:2.3:a:getlaminas:laminas-http:*:*:*:*:*:*:*:*
cpe:2.3:a:zend:zend_framework:3.0.0:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 7.5
v3 : 9.8
CWE CWE-502

05 Jan 2021, 18:15

Type Values Removed Values Added
Summary Zend Framework 3.0.0 has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: the code may be related to Laminas Project laminas-http. Zend Framework is no longer supported by the maintainer. However, not all Zend Framework 3.0.0 vulnerabilities exist in a Laminas Project release. ** DISPUTED ** Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized.
References
  • (MISC) https://github.com/laminas/laminas-http/pull/48 -
  • (MISC) https://github.com/laminas/laminas-http/releases/tag/2.14.2 -

04 Jan 2021, 03:15

Type Values Removed Values Added
New CVE

Information

Published : 2021-01-04 03:15

Updated : 2024-05-17 02:00


NVD link : CVE-2021-3007

Mitre link : CVE-2021-3007

CVE.ORG link : CVE-2021-3007


JSON object : View

Products Affected

zend

  • zend_framework

getlaminas

  • laminas-http
CWE
CWE-502

Deserialization of Untrusted Data