CVE-2021-32715

hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.
Configurations

Configuration 1 (hide)

cpe:2.3:a:hyper:hyper:*:*:*:*:*:rust:*:*

Information

Published : 2021-07-07 20:15

Updated : 2021-07-22 12:49


NVD link : CVE-2021-32715

Mitre link : CVE-2021-32715


JSON object : View

Products Affected

hyper

  • hyper
CWE
CWE-444

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')