CVE-2021-39137

go-ethereum is the official Go implementation of the Ethereum protocol. In affected versions a consensus-vulnerability in go-ethereum (Geth) could cause a chain split, where vulnerable versions refuse to accept the canonical chain. Further details about the vulnerability will be disclosed at a later date. A patch is included in the upcoming `v1.10.8` release. No workaround are available.
Configurations

Configuration 1 (hide)

cpe:2.3:a:ethereum:go_ethereum:*:*:*:*:*:*:*:*

History

31 Aug 2021, 16:04

Type Values Removed Values Added
CVSS v2 : unknown
v3 : 6.5
v2 : 5.0
v3 : 7.5
CPE cpe:2.3:a:ethereum:go_ethereum:*:*:*:*:*:*:*:*
References (MISC) https://github.com/ethereum/go-ethereum/releases/tag/v1.10.8 - (MISC) https://github.com/ethereum/go-ethereum/releases/tag/v1.10.8 - Third Party Advisory
References (CONFIRM) https://github.com/ethereum/go-ethereum/security/advisories/GHSA-9856-9gg9-qcmq - (CONFIRM) https://github.com/ethereum/go-ethereum/security/advisories/GHSA-9856-9gg9-qcmq - Third Party Advisory

24 Aug 2021, 17:15

Type Values Removed Values Added
New CVE

Information

Published : 2021-08-24 16:15

Updated : 2021-08-31 16:04


NVD link : CVE-2021-39137

Mitre link : CVE-2021-39137


JSON object : View

Products Affected

ethereum

  • go_ethereum
CWE
CWE-436

Interpretation Conflict