CVE-2021-40030

The My HUAWEI app has a defect in the design. Successful exploitation of this vulnerability may affect data confidentiality.
Configurations

Configuration 1 (hide)

OR cpe:2.3:o:huawei:magic_ui:3.1.1:*:*:*:*:*:*:*
cpe:2.3:o:huawei:magic_ui:3.1.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:10.1.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:10.1.1:*:*:*:*:*:*:*
cpe:2.3:o:huawei:magic_ui:4.0.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:11.0.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:harmonyos:2.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:12.0.0:*:*:*:*:*:*:*

History

12 Aug 2022, 21:20

Type Values Removed Values Added
References (MISC) https://device.harmonyos.com/en/docs/security/update/security-bulletins-phones-202208-0000001363876177 - (MISC) https://device.harmonyos.com/en/docs/security/update/security-bulletins-phones-202208-0000001363876177 - Vendor Advisory
References (MISC) https://consumer.huawei.com/en/support/bulletin/2022/8/ - (MISC) https://consumer.huawei.com/en/support/bulletin/2022/8/ - Vendor Advisory
CPE cpe:2.3:o:huawei:emui:12.0.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:magic_ui:3.1.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:harmonyos:2.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:magic_ui:4.0.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:11.0.0:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:10.1.1:*:*:*:*:*:*:*
cpe:2.3:o:huawei:magic_ui:3.1.1:*:*:*:*:*:*:*
cpe:2.3:o:huawei:emui:10.1.0:*:*:*:*:*:*:*
CWE NVD-CWE-noinfo
First Time Huawei harmonyos
Huawei
Huawei magic Ui
Huawei emui
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 7.5

10 Aug 2022, 20:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-08-10 20:15

Updated : 2022-08-12 21:20


NVD link : CVE-2021-40030

Mitre link : CVE-2021-40030


JSON object : View

Products Affected

huawei

  • magic_ui
  • emui
  • harmonyos