CVE-2021-41556

sqclass.cpp in Squirrel through 2.2.5 and 3.x through 3.1 allows an out-of-bounds read (in the core interpreter) that can lead to Code Execution. If a victim executes an attacker-controlled squirrel script, it is possible for the attacker to break out of the squirrel script sandbox even if all dangerous functionality such as File System functions has been disabled. An attacker might abuse this bug to target (for example) Cloud services that allow customization via SquirrelScripts, or distribute malware through video games that embed a Squirrel Engine.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:squirrel-lang:squirrel:*:*:*:*:*:*:*:*
cpe:2.3:a:squirrel-lang:squirrel:*:*:*:*:*:*:*:*

History

05 Aug 2022, 22:30

Type Values Removed Values Added
References (MISC) https://github.com/albertodemichelis/squirrel/commit/23a0620658714b996d20da3d4dd1a0dcf9b0bd98 - (MISC) https://github.com/albertodemichelis/squirrel/commit/23a0620658714b996d20da3d4dd1a0dcf9b0bd98 - Patch, Third Party Advisory
References (MISC) http://www.squirrel-lang.org/#download - (MISC) http://www.squirrel-lang.org/#download - Third Party Advisory
References (MISC) https://blog.sonarsource.com/squirrel-vm-sandbox-escape/ - (MISC) https://blog.sonarsource.com/squirrel-vm-sandbox-escape/ - Exploit, Third Party Advisory
First Time Squirrel-lang squirrel
Squirrel-lang
CPE cpe:2.3:a:squirrel-lang:squirrel:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 10.0
CWE CWE-125

28 Jul 2022, 21:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-07-28 21:15

Updated : 2022-08-05 22:30


NVD link : CVE-2021-41556

Mitre link : CVE-2021-41556


JSON object : View

Products Affected

squirrel-lang

  • squirrel
CWE
CWE-125

Out-of-bounds Read