CVE-2021-42735

Adobe Photoshop version 22.5.1 (and earlier versions ) is affected by an Access of Memory Location After End of Buffer vulnerability, potentially resulting in arbitrary code execution in the context of the current user. User interaction is required to exploit this vulnerability.
Configurations

Configuration 1 (hide)

AND
cpe:2.3:a:adobe:photoshop:*:*:*:*:*:*:*:*
OR cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:*

History

24 Jun 2022, 17:12

Type Values Removed Values Added
CPE cpe:2.3:a:adobe:photoshop:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:*
References (MISC) https://helpx.adobe.com/security/products/photoshop/apsb21-109.html - (MISC) https://helpx.adobe.com/security/products/photoshop/apsb21-109.html - Vendor Advisory
First Time Adobe photoshop
Adobe
Apple macos
Microsoft
Microsoft windows
Apple
CVSS v2 : unknown
v3 : 7.8
v2 : 6.8
v3 : 7.8

15 Jun 2022, 20:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-06-15 20:15

Updated : 2022-06-24 17:12


NVD link : CVE-2021-42735

Mitre link : CVE-2021-42735


JSON object : View

Products Affected

apple

  • macos

adobe

  • photoshop

microsoft

  • windows
CWE
CWE-788

Access of Memory Location After End of Buffer