CVE-2022-0318

Heap-based Buffer Overflow in vim/vim prior to 8.2.
Configurations

Configuration 1 (hide)

cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:*

History

24 Nov 2022, 16:15

Type Values Removed Values Added
References
  • (MLIST) https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html -

04 Nov 2022, 15:49

Type Values Removed Values Added
References (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/43 - (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/43 - Mailing List, Third Party Advisory
References (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/41 - (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/41 - Mailing List, Third Party Advisory
References (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/28 - (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/28 - Mailing List, Third Party Advisory

31 Oct 2022, 00:15

Type Values Removed Values Added
References
  • (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/43 -

30 Oct 2022, 23:15

Type Values Removed Values Added
References
  • (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/41 -
  • (FULLDISC) http://seclists.org/fulldisclosure/2022/Oct/28 -

28 Oct 2022, 21:08

Type Values Removed Values Added
References (CONFIRM) https://support.apple.com/kb/HT213444 - (CONFIRM) https://support.apple.com/kb/HT213444 - Third Party Advisory
References (CONFIRM) https://support.apple.com/kb/HT213488 - (CONFIRM) https://support.apple.com/kb/HT213488 - Third Party Advisory
CWE CWE-122 CWE-787
First Time Apple macos
Apple
CPE cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:*

27 Oct 2022, 20:15

Type Values Removed Values Added
References
  • (CONFIRM) https://support.apple.com/kb/HT213444 -

25 Oct 2022, 21:15

Type Values Removed Values Added
References
  • (CONFIRM) https://support.apple.com/kb/HT213488 -

29 Aug 2022, 18:59

Type Values Removed Values Added
References (GENTOO) https://security.gentoo.org/glsa/202208-32 - (GENTOO) https://security.gentoo.org/glsa/202208-32 - Third Party Advisory

21 Aug 2022, 07:15

Type Values Removed Values Added
References
  • (GENTOO) https://security.gentoo.org/glsa/202208-32 -

27 Jan 2022, 14:17

Type Values Removed Values Added
CPE cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*
First Time Vim vim
Vim
CVSS v2 : unknown
v3 : unknown
v2 : 7.5
v3 : 9.8
References (CONFIRM) https://huntr.dev/bounties/0d10ba02-b138-4e68-a284-67f781a62d08 - (CONFIRM) https://huntr.dev/bounties/0d10ba02-b138-4e68-a284-67f781a62d08 - Exploit, Patch, Third Party Advisory
References (MISC) https://github.com/vim/vim/commit/57df9e8a9f9ae1aafdde9b86b10ad907627a87dc - (MISC) https://github.com/vim/vim/commit/57df9e8a9f9ae1aafdde9b86b10ad907627a87dc - Patch, Third Party Advisory

21 Jan 2022, 14:15

Type Values Removed Values Added
Summary Heap-based Buffer Overflow in Conda vim prior to 8.2. Heap-based Buffer Overflow in vim/vim prior to 8.2.

21 Jan 2022, 12:54

Type Values Removed Values Added
New CVE

Information

Published : 2022-01-21 12:15

Updated : 2022-11-24 16:15


NVD link : CVE-2022-0318

Mitre link : CVE-2022-0318


JSON object : View

Products Affected

apple

  • macos

vim

  • vim
CWE
CWE-787

Out-of-bounds Write