CVE-2022-1621

Heap buffer overflow in vim_strncpy find_word in GitHub repository vim/vim prior to 8.2.4919. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possible remote execution
Configurations

Configuration 1 (hide)

cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*

History

18 May 2022, 11:15

Type Values Removed Values Added
References
  • (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HIP7KG7TVS5YF3QREAY2GOGUT3YUBZAI/ -

16 May 2022, 22:15

Type Values Removed Values Added
References
  • (MLIST) https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html -

16 May 2022, 15:22

Type Values Removed Values Added
CWE CWE-787
References (CONFIRM) https://huntr.dev/bounties/520ce714-bfd2-4646-9458-f52cd22bb2fb - (CONFIRM) https://huntr.dev/bounties/520ce714-bfd2-4646-9458-f52cd22bb2fb - Exploit, Third Party Advisory
References (MISC) https://github.com/vim/vim/commit/7c824682d2028432ee082703ef0ab399867a089b - (MISC) https://github.com/vim/vim/commit/7c824682d2028432ee082703ef0ab399867a089b - Patch, Third Party Advisory
CPE cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 6.8
v3 : 7.8
First Time Vim
Vim vim

10 May 2022, 17:15

Type Values Removed Values Added
Summary Heap buffer overflow in vim_strncpy find_word in GitHub repository vim/vim prior to 8.2. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possible remote execution Heap buffer overflow in vim_strncpy find_word in GitHub repository vim/vim prior to 8.2.4919. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possible remote execution

10 May 2022, 14:34

Type Values Removed Values Added
New CVE

Information

Published : 2022-05-10 14:15

Updated : 2022-05-18 11:15


NVD link : CVE-2022-1621

Mitre link : CVE-2022-1621


JSON object : View

Products Affected

vim

  • vim
CWE
CWE-787

Out-of-bounds Write