CVE-2022-1707

The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.
Configurations

Configuration 1 (hide)

cpe:2.3:a:gtm4wp:google_tag_manager:*:*:*:*:*:wordpress:*:*

History

17 Jun 2022, 23:23

Type Values Removed Values Added
First Time Gtm4wp google Tag Manager
Gtm4wp
CWE CWE-79
CVSS v2 : unknown
v3 : unknown
v2 : 4.3
v3 : 6.1
CPE cpe:2.3:a:gtm4wp:google_tag_manager:*:*:*:*:*:wordpress:*:*
References (MISC) https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1707 - (MISC) https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1707 - Third Party Advisory
References (MISC) https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L782 - (MISC) https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L782 - Exploit, Third Party Advisory
References (MISC) https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L298 - (MISC) https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L298 - Exploit, Third Party Advisory
References (MISC) https://github.com/duracelltomi/gtm4wp/issues/224 - (MISC) https://github.com/duracelltomi/gtm4wp/issues/224 - Issue Tracking, Third Party Advisory

13 Jun 2022, 13:26

Type Values Removed Values Added
New CVE

Information

Published : 2022-06-13 13:15

Updated : 2022-06-17 23:23


NVD link : CVE-2022-1707

Mitre link : CVE-2022-1707


JSON object : View

Products Affected

gtm4wp

  • google_tag_manager
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')