CVE-2022-1896

The underConstruction WordPress plugin before 1.21 does not sanitise or escape the "Display a custom page using your own HTML" setting before outputting it, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiletred_html capability is disallowed.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:underconstruction_project:underconstruction:*:*:*:*:*:wordpress:*:*

History

28 Jun 2022, 17:02

Type Values Removed Values Added
References (MISC) https://wpscan.com/vulnerability/3e8bd875-2435-4a15-8ee8-8a00882b499c - (MISC) https://wpscan.com/vulnerability/3e8bd875-2435-4a15-8ee8-8a00882b499c - Exploit, Third Party Advisory
CVSS v2 : unknown
v3 : unknown
v2 : 3.5
v3 : 4.8
First Time Underconstruction Project
Underconstruction Project underconstruction
CPE cpe:2.3:a:underconstruction_project:underconstruction:*:*:*:*:*:wordpress:*:*

20 Jun 2022, 11:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-06-20 11:15

Updated : 2022-06-28 17:02


NVD link : CVE-2022-1896

Mitre link : CVE-2022-1896


JSON object : View

Products Affected

underconstruction_project

  • underconstruction
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')