CVE-2022-22433

IBM Robotic Process Automation 21.0.1 and 21.0.2 is vulnerable to External Service Interaction attack, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability to induce the application to perform server-side DNS lookups or HTTP requests to arbitrary domain names. By submitting suitable payloads, an attacker can cause the application server to attack other systems that it can interact with. IBM X-Force ID: 224156.
References
Configurations

Configuration 1 (hide)

AND
OR cpe:2.3:a:ibm:robotic_process_automation:21.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:robotic_process_automation:*:*:*:*:*:*:*:*
cpe:2.3:a:ibm:robotic_process_automation_as_a_service:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*

History

16 May 2022, 13:47

Type Values Removed Values Added
References (XF) https://exchange.xforce.ibmcloud.com/vulnerabilities/224156 - (XF) https://exchange.xforce.ibmcloud.com/vulnerabilities/224156 - VDB Entry, Vendor Advisory
References (CONFIRM) https://www.ibm.com/support/pages/node/6573913 - (CONFIRM) https://www.ibm.com/support/pages/node/6573913 - Patch, Vendor Advisory
First Time Ibm robotic Process Automation
Ibm
Microsoft
Microsoft windows
Ibm robotic Process Automation As A Service
CPE cpe:2.3:a:ibm:robotic_process_automation:21.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:robotic_process_automation_as_a_service:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
cpe:2.3:a:ibm:robotic_process_automation:*:*:*:*:*:*:*:*
CWE CWE-20
CVSS v2 : unknown
v3 : unknown
v2 : 5.0
v3 : 7.5

05 May 2022, 17:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-05-05 16:15

Updated : 2022-05-16 13:47


NVD link : CVE-2022-22433

Mitre link : CVE-2022-22433


JSON object : View

Products Affected

microsoft

  • windows

ibm

  • robotic_process_automation_as_a_service
  • robotic_process_automation
CWE
CWE-20

Improper Input Validation