CVE-2022-22893

Jerryscript 3.0.0 was discovered to contain a stack overflow via vm_loop.lto_priv.304 in /jerry-core/vm/vm.c.
References
Link Resource
https://github.com/jerryscript-project/jerryscript/issues/4901 Exploit Issue Tracking Patch Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:jerryscript:jerryscript:3.0.0:*:*:*:*:*:*:*

History

26 Jan 2022, 21:12

Type Values Removed Values Added
References (MISC) https://github.com/jerryscript-project/jerryscript/issues/4901 - (MISC) https://github.com/jerryscript-project/jerryscript/issues/4901 - Exploit, Issue Tracking, Patch, Third Party Advisory
CWE CWE-787
First Time Jerryscript
Jerryscript jerryscript
CPE cpe:2.3:a:jerryscript:jerryscript:3.0.0:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 6.8
v3 : 7.8

21 Jan 2022, 00:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-01-21 00:15

Updated : 2022-01-26 21:12


NVD link : CVE-2022-22893

Mitre link : CVE-2022-22893


JSON object : View

Products Affected

jerryscript

  • jerryscript
CWE
CWE-787

Out-of-bounds Write