CVE-2022-22895

Jerryscript 3.0.0 was discovered to contain a heap-buffer-overflow via ecma_utf8_string_to_number_by_radix in /jerry-core/ecma/base/ecma-helpers-conversion.c.
References
Link Resource
https://github.com/jerryscript-project/jerryscript/issues/4850 Issue Tracking Patch Third Party Advisory
https://github.com/jerryscript-project/jerryscript/issues/4882 Exploit Issue Tracking Patch Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:jerryscript:jerryscript:3.0.0:*:*:*:*:*:*:*

History

26 Jan 2022, 21:14

Type Values Removed Values Added
CVSS v2 : unknown
v3 : unknown
v2 : 6.8
v3 : 7.8
References (MISC) https://github.com/jerryscript-project/jerryscript/issues/4882 - (MISC) https://github.com/jerryscript-project/jerryscript/issues/4882 - Exploit, Issue Tracking, Patch, Third Party Advisory
References (MISC) https://github.com/jerryscript-project/jerryscript/issues/4850 - (MISC) https://github.com/jerryscript-project/jerryscript/issues/4850 - Issue Tracking, Patch, Third Party Advisory
First Time Jerryscript
Jerryscript jerryscript
CWE CWE-787
CPE cpe:2.3:a:jerryscript:jerryscript:3.0.0:*:*:*:*:*:*:*

21 Jan 2022, 00:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-01-21 00:15

Updated : 2022-01-26 21:14


NVD link : CVE-2022-22895

Mitre link : CVE-2022-22895


JSON object : View

Products Affected

jerryscript

  • jerryscript
CWE
CWE-787

Out-of-bounds Write