CVE-2022-23203

Adobe Photoshop versions 22.5.4 (and earlier) and 23.1 (and earlier) are affected by a buffer overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current user. Exploitation requires user interaction in that a victim must open a crafted file in Photoshop.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:adobe:photoshop:*:*:*:*:*:*:*:*
cpe:2.3:a:adobe:photoshop:*:*:*:*:*:*:*:*

History

24 Feb 2022, 15:26

Type Values Removed Values Added
CPE cpe:2.3:a:adobe:photoshop:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : 6.8
v3 : 7.8
References (MISC) https://helpx.adobe.com/security/products/photoshop/apsb22-08.html - (MISC) https://helpx.adobe.com/security/products/photoshop/apsb22-08.html - Vendor Advisory
First Time Adobe photoshop
Adobe

16 Feb 2022, 18:00

Type Values Removed Values Added
New CVE

Information

Published : 2022-02-16 17:15

Updated : 2022-02-24 15:26


NVD link : CVE-2022-23203

Mitre link : CVE-2022-23203


JSON object : View

Products Affected

adobe

  • photoshop
CWE
CWE-120

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')