CVE-2022-25857

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
Configurations

Configuration 1 (hide)

cpe:2.3:a:snakeyaml_project:snakeyaml:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

History

08 Aug 2023, 14:22

Type Values Removed Values Added
CWE CWE-400 CWE-776

06 Oct 2022, 15:30

Type Values Removed Values Added
References (MLIST) https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html - (MLIST) https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html - Mailing List, Third Party Advisory
First Time Debian debian Linux
Debian
CPE cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

03 Oct 2022, 00:15

Type Values Removed Values Added
References
  • (MLIST) https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html -

01 Sep 2022, 20:40

Type Values Removed Values Added
First Time Snakeyaml Project
Snakeyaml Project snakeyaml
CWE CWE-400
References (CONFIRM) https://bitbucket.org/snakeyaml/snakeyaml/commits/fc300780da21f4bb92c148bc90257201220cf174 - (CONFIRM) https://bitbucket.org/snakeyaml/snakeyaml/commits/fc300780da21f4bb92c148bc90257201220cf174 - Patch, Third Party Advisory
References (CONFIRM) https://github.com/snakeyaml/snakeyaml/commit/fc300780da21f4bb92c148bc90257201220cf174 - (CONFIRM) https://github.com/snakeyaml/snakeyaml/commit/fc300780da21f4bb92c148bc90257201220cf174 - Patch, Third Party Advisory
References (CONFIRM) https://bitbucket.org/snakeyaml/snakeyaml/issues/525 - (CONFIRM) https://bitbucket.org/snakeyaml/snakeyaml/issues/525 - Exploit, Issue Tracking, Third Party Advisory
References (CONFIRM) https://security.snyk.io/vuln/SNYK-JAVA-ORGYAML-2806360 - (CONFIRM) https://security.snyk.io/vuln/SNYK-JAVA-ORGYAML-2806360 - Exploit, Patch, Third Party Advisory
CPE cpe:2.3:a:snakeyaml_project:snakeyaml:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 7.5

30 Aug 2022, 06:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-08-30 05:15

Updated : 2023-12-10 14:35


NVD link : CVE-2022-25857

Mitre link : CVE-2022-25857

CVE.ORG link : CVE-2022-25857


JSON object : View

Products Affected

snakeyaml_project

  • snakeyaml

debian

  • debian_linux
CWE
CWE-776

Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')