CVE-2022-28711

A memory corruption vulnerability exists in the cgi.c unescape functionality of ArduPilot APWeb master branch 50b6b7ac - master branch 46177cb9. A specially-crafted HTTP request can lead to memory corruption. An attacker can send a network request to trigger this vulnerability.
Configurations

Configuration 1 (hide)

cpe:2.3:a:ardupilot:apweb:-:*:*:*:*:*:*:*

History

04 Feb 2023, 00:16

Type Values Removed Values Added
References (MISC) https://talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - Broken Link (MISC) https://talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - Exploit, Third Party Advisory
References (MISC) https://www.talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - (MISC) https://www.talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - Exploit, Third Party Advisory

27 Jul 2022, 18:15

Type Values Removed Values Added
References
  • (MISC) https://www.talosintelligence.com/vulnerability_reports/TALOS-2022-1512 -

22 Apr 2022, 18:19

Type Values Removed Values Added
CVSS v2 : unknown
v3 : unknown
v2 : 7.5
v3 : 9.8
CWE CWE-787
References (MISC) https://talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - (MISC) https://talosintelligence.com/vulnerability_reports/TALOS-2022-1512 - Broken Link
CPE cpe:2.3:a:ardupilot:apweb:-:*:*:*:*:*:*:*
First Time Ardupilot
Ardupilot apweb

14 Apr 2022, 20:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-04-14 20:15

Updated : 2023-02-04 00:16


NVD link : CVE-2022-28711

Mitre link : CVE-2022-28711


JSON object : View

Products Affected

ardupilot

  • apweb
CWE
CWE-787

Out-of-bounds Write