CVE-2022-30293

In WebKitGTK through 2.36.0 (and WPE WebKit), there is a heap-based buffer overflow in WebCore::TextureMapperLayer::setContentsLayer in WebCore/platform/graphics/texmap/TextureMapperLayer.cpp.
Configurations

Configuration 1 (hide)

cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:*

History

14 May 2022, 02:47

Type Values Removed Values Added
CPE cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:*
References (MISC) https://github.com/ChijinZ/security_advisories/tree/master/webkitgtk-2.36.0 - (MISC) https://github.com/ChijinZ/security_advisories/tree/master/webkitgtk-2.36.0 - Exploit, Third Party Advisory
References (MISC) https://bugs.webkit.org/show_bug.cgi?id=237187 - (MISC) https://bugs.webkit.org/show_bug.cgi?id=237187 - Patch, Vendor Advisory
First Time Webkitgtk
Webkitgtk webkitgtk
CWE CWE-787
CVSS v2 : unknown
v3 : unknown
v2 : 5.1
v3 : 7.5

06 May 2022, 05:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-05-06 05:15

Updated : 2022-05-14 02:47


NVD link : CVE-2022-30293

Mitre link : CVE-2022-30293


JSON object : View

Products Affected

webkitgtk

  • webkitgtk
CWE
CWE-787

Out-of-bounds Write